The Speed Test
 

How to setup a rate-limit on a cisco router

This was the configuration that I use on the Cisco 2651.

!!!!Creates the Class that points to the Access list that tells
!!!!the router what traffic to include in the rate limit.

class-map match-any SpecificHost
match access-group 115

!!!!Sets the policy to 8000000 witch is 1Mbps

policy-map SqueezeHost
class SpecificHost
police 8000000 250000 250000 conform-action transmit exceed-action drop

!!!!Apply the service-policy to the interface going to the hosts that you want
!!!!to rate limit

interface FastEthernet0/0
ip address 192.168.140.1 255.255.255.0 secondary
ip address 192.168.160.1 255.255.255.0 secondary
ip address 192.168.120.1 255.255.255.0 secondary
ip address 192.168.100.1 255.255.255.0 secondary
ip nat inside
service-policy input SqueezeHost
service-policy output SqueezeHost
no ip mroute-cache
speed 10
full-duplex
no cdp enable

!!!Define your access list for the ranges that you want
!!!to rate limit.

access-list 115 permit ip 192.168.140.0 0.0.0.255 any
access-list 115 permit ip 192.168.160.0 0.0.0.255 any
access-list 115 permit ip 192.168.120.0 0.0.0.255 any
access-list 115 permit ip 192.168.100.0 0.0.0.255 any




home
Speed Test
Setting up Rancid on Freebsd 7.0
Setting up TACACS on Freebsd 7.0
Rate limiting host on a Cisco Router
Why is my internet slow?
How to enable SSH login access to a Cisco router?
Enhanced Interior Gateway Routing Protocol (EIGRP)
BlogCatalog
Privacy Policy
jrichesin@gmail.com
Copyright ©2010 thespeedtest.com